Görevleri düzenli aralıklarla çalışacak şekilde zamanlama

Görev Zamanlayıcı, programları (Disk Birleştiricisi gibi) ve diğer yardımcı programları, sizin için en uygun zamanda düzenli aralıklarla çalışacak şekilde zamanlamanızı sağlayan bir araçtır. Görev Zamanlayıcı, Windows'u her başlattığınızda başlar ve artalanda çalışır.

Görev Zamanlayıcı'yı, Başlat'ı tıklatıp, Programlar'ı, Donatılar'ı, Sistem Araçları'nı seçip, sonra Zamanlanmış Görevler'i tıklatarak da başlatabilirsiniz.

Görev Zamanlayıcı'yı açtığınızda aşağıdakileri yapabilirsiniz:

  • Bir görevi her gün, haftada bir, ayda bir veya bilgisayarın başlatılması ya da boşta kalması gibi belirli zamanlarda çalışacak şekilde zamanlama.
  • Varolan bir görev için zamanlamayı değiştirme veya görevi kapatma.
  • Zamanlanmış görevin çalışma şeklini özelleştirme.


Yeni görev zamanlama

  1. Başlat'ı tıklatın, Programlar'ı, Donatılar'ı, Sistem Araçları'nı seçin ve sonra Zamanlanmış Görevler'i tıklatın.
  2. Zamanlanmış Görev Ekle'yi çift tıklatın.
  3. Zamanlanmış Görev sihirbazındaki yönergeleri izleyin:

    4. Görev için, (her çalıştığında yinelenerek çalışacak şekilde ayarlamak gibi) gelişmiş ayarlar belirlemek istiyorsanız, sihirbazın son penceresinde, Gelişmiş özellikleri aç onay kutusunu seçin.

Notlar

  • Görev programı parametre gerektiriyorsa, sihirbazın son ekranında Gelişmiş özellikleri aç onay kutusunu seçin, Son'u tıklatın, Görev sekmesini tıklatın ve Çalıştır kutusunda görev yolunun ardından parametreleri yazın.
  • Bilgisayarınız açık olduğu sürece, Windows'da oturum açılmış olsun veya olmasın, zamanlamış görev çalışacaktır. Windows'da oturum açılmadığında görevlerin çalışmasını istemiyorsanız, oturum kapatmadan önce Zamanlanmış Görevler klasörünü açın ve Gelişmiş menüsünden Görev Zamanlayıcıyı Kullanmayı Durdur seçeneğini tıklatın. Yeniden oturum açtığınızda, Görev Zamanlayıcı'yı kullanmaya devam etmek için, Zamanlanmış Görevler klasörünü açın ve Gelişmiş menüsünden Görev Zamanlayıcıyı Kullanmaya Başla seçeneğini tıklatın.
  • Bilgisayarınızın sistem tarihi ve saatinin doğru olduğundan emin olun. Görev Zamanlayıcı bu bilgileri, zamanlanmış görevleri çalıştıracağı zamanı belirlemek için kullanır. Tarihi ve saati değiştirmek için, görev çubuğundaki saati çift tıklatın.

İlgili Konular


Zamanlanmış bir görevi değiştirme

  1. Başlat'ı tıklatın, Programlar'ı, Donatılar'ı, Sistem Araçları'nı seçin ve sonra Zamanlanmış Görevler'i tıklatın.
  2. Değiştirmek istediğiniz görevi sağ tıklatın ve sonra Özellikler'i tıklatın.
  3. Aşağıdakilerden birini veya birkaçını yapın:
    • Çalıştırmak istediğiniz programı değiştirmek için, Çalıştır kutusunda, görevin yolunu yazın veya Gözat'ı tıklatın.
    • Görevin zamanlamasını değiştirmek için, Zamanlama sekmesini tıklatın.
    • Görev ayarlarını özelleştirmek için, Ayarlar sekmesini tıklatın.

Notlar

  • Görev programı için parametre gerekiyorsa, bunları görev yolundan sonra Çalıştır kutusuna yazın.
  • Görev programı yolu boşluk içeriyorsa, tüm görev yolunu çift tırnak imi (“) içine alın.


Zamanlanmış bir görevi kaldırma

  1. Başlat'ı tıklatın, Programlar'ı, Donatılar'ı, Sistem Araçları'nı seçin ve sonra Zamanlanmış Görevler'i tıklatın.
  2. Kaldırmak istediğiniz görevi sağ tıklatın ve sonra Sil'i tıklatın.

Not

  • Zamanlanmış bir görev kaldırıldığında, görev yalnızca Zamanlanmış Görevler klasöründen silinir. Görevle ilişkili program, bilgisayarınızdan kaldırılmaz.


Çalışmakta olan zamanlanmış görevi durdurma

  1. Başlat'ı tıklatın, Programlar'ı, Donatılar'ı, Sistem Araçları'nı seçin ve sonra Zamanlanmış Görevler'i tıklatın.
  2. Durdurmak istediğiniz görevi sağ tıklatın ve sonra Görevi Sonlandır'ı tıklatın.

Notlar

  • Zamanlanmış bir görev başka bir programı başlatırsa, bu komut yalnızca ilk zamanlanmış görevi durdurur, ikinciyi etkilemez.
  • Bir görevi yeniden başlatmak için, görevi sağ tıklatın ve sonra Çalıştır'ı tıklatın.
  • Bilgisayarınız açık olduğu sürece, Windows'da oturum açılmış olsun veya olmasın, zamanlamış görev çalışacaktır. Windows'da oturum açılmadığında görevlerin çalışmasını istemiyorsanız, oturumu kapatmadan önce Zamanlanmış Görevler klasörünü açın ve Gelişmiş menüsünden Görev Zamanlayıcıyı Kullanmayı Durdur seçeneğini tıklatın. Yeniden oturum açtığınızda, Görev Zamanlayıcı'yı kullanmaya devam etmek için, Zamanlanmış Görevler klasörünü açın ve Gelişmiş menüsünden Görev Zamanlayıcıyı Kullanmaya Başla seçeneğini tıklatın.


Görevi hemen çalıştırma

  1. Başlat'ı tıklatın, Programlar'ı, Donatılar'ı, Sistem Araçları'nı seçin ve sonra Zamanlanmış Görevler'i tıklatın.
  2. Başlatmak istediğiniz görevi sağ tıklatın ve sonra Çalıştır'ı tıklatın.

Notlar

  • Dosya menüsünü ve sonra Zamanlanmış Görevi Sonlandır'ı tıklatarak, görevi sonlandırabilirsiniz.
  • Çalışması gereken bir görev çalışmazsa, nedenini belirlemek için günlük dosyasını inceleyin. Gelişmiş menüsünden Günlüğü Göster'i tıklatın.


Geçmişte zamanlanmış görevlerin günlüğünü görüntüleme

  1. Başlat'ı tıklatın, Programlar'ı, Donatılar'ı, Sistem Araçları'nı seçin ve sonra Zamanlanmış Görevler'i tıklatın.
  2. Gelişmiş menüsünden Günlüğü Göster'i tıklatın.


Uzak bilgisayardaki zamanlanmış görevleri görüntüleme

  1. Ağ Bağlantılarım simgesini çift tıklatın.
  2. Zamanlanmış görevleri görüntülemek istediğiniz bilgisayarı çift tıklatın.
  3. Zamanlanmış Görevler klasörünü çift tıklatın.

Not

  • Uzaktaki bir bilgisayarda bulunan görevleri düzenleyebilmeniz için, bu bilgisayarda uzak kayıt yazılımının yüklü olması ve x'in Zamanlanmış Görevler'in bulunduğu sabit diski gösterdiği x$ paylaşımını paylaşıyor olması gerekir. Bilgisayar, ayrıca kullanıcı hesabınızı özellikle uzak kayıt erişimine sahip olarak listelemelidir. Bir bilgisayara hangi kullanıcıların uzak kayıt erişimi olacağını, Denetim Masası'ndaki Parolalar'ı tıklatarak belirtebilirsiniz.


Tüm zamanlanmış görevleri geçici olarak kapatma

  1. Başlat'ı tıklatın, Programlar'ı, Donatılar'ı, Sistem Araçları'nı seçin ve sonra Zamanlanmış Görevler'i tıklatın.
  2. Gelişmiş menüsünden Görev Zamanlayıcıyı Duraklat'ı tıklatın.

    Başka bir program (örneğin bir oyun) çalıştırıyorsanız veya yazılım yüklüyorsanız ve görevlerin aynı anda çalışmasını istemiyorsanız, bu uygulama kullanışlıdır.

Notlar

  • Görev Zamanlayıcı'nın duraklatıldığı süre içinde çalışmaya başlaması gereken görevler, bir sonraki zamanlamaya kadar çalıştırılmazlar.
  • Tüm görevlerin zamanlamalarını başlatmak için, Gelişmiş menüsünden Görev Zamanlayıcıya Devam Et'i tıklatın.


Görev Zamanlayıcı'yı kapatma

  1. Başlat'ı tıklatın, Programlar'ı, Donatılar'ı, Sistem Araçları'nı seçin ve sonra Zamanlanmış Görevler'i tıklatın.
  2. Gelişmiş menüsünden Görev Zamanlayıcıyı Kullanmayı Durdur'u tıklatın.

Not

  • Görev Zamanlayıcı'yı kapattığınızda, zamanlanmış görevleriniz çalışmayacaktır ve Windows'u bir daha başlattığınızda Görev Zamanlayıcı otomatik olarak başlamayacaktır.


Görev Zamanlayıcı Sorunlarını Giderme

Zamanladığınız görev, beklediğiniz zamanda çalışmazsa, görev listesinde bu görevi sağ tıklatın ve sonra Özellikler'i tıklatın. Görev sekmesinde, Etkin onay kutusunun seçili olduğundan emin olun. Zamanlama sekmesinde, zamanlamanın doğru ayarlandığından emin olun.

Bir görev programı doğru çalışmazsa, komut değişkenlerini sağlamanız gerekebilir. Program ve değişkenleri hakkında daha fazla bilgi edinmek için, aşağıdakilerden birini deneyin:

  • Programın çevrimiçi yardımı varsa, bu yardıma bakın.
  • Komut satırında aşağıdakini yazmayı deneyin, burada program, programın adıdır.
    program /?


Zamanlanmış Görevler klasörünü açma

  • Başlat'ı tıklatın, Programlar'ı, Donatılar'ı, Sistem Araçları'nı seçin ve sonra Zamanlanmış Görevler'i tıklatın.